rules 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. #export DH_VERBOSE=1
  4. SRCTOP = `pwd`
  5. DESTDIR = $(SRCTOP)/debian/tmp
  6. INST_OWN = -o root -g root
  7. MAKE_DIR = install -p -d $(INST_OWN) -m 755
  8. INST_FILE = install -c $(INST_OWN) -m 644
  9. INST_PROG = install -c $(INST_OWN) -m 755 -s
  10. INST_SCRIPT = install -c $(INST_OWN) -m 755
  11. build: build-stamp
  12. build-stamp:
  13. dh_testdir
  14. ./configure --prefix=/usr
  15. touch build-stamp
  16. clean:
  17. dh_testdir
  18. dh_testroot
  19. -$(MAKE) distclean
  20. rm -f build-stamp
  21. dh_clean
  22. install: build
  23. dh_testdir
  24. dh_testroot
  25. dh_prep
  26. dh_installdirs
  27. $(MAKE) install DESTDIR=$(DESTDIR) LIBTOOL=libtool
  28. dh_install
  29. # Build architecture-independent files here.
  30. binary-indep: build install
  31. dh_testdir
  32. dh_testroot
  33. dh_installchangelogs ChangeLog
  34. dh_installdocs
  35. dh_installexamples
  36. dh_installdebconf
  37. dh_installman
  38. dh_link
  39. dh_compress
  40. dh_fixperms
  41. dh_strip
  42. dh_installdeb
  43. dh_shlibdeps
  44. dh_gencontrol
  45. dh_md5sums
  46. dh_builddeb
  47. # Build architecture-dependent files here.
  48. binary-arch:
  49. binary: binary-indep binary-arch
  50. .PHONY: build clean binary-indep binary-arch binary install