The klish is a framework for implementing a CISCO-like CLI on a UNIX systems. It is configurable by XML files. http://klish.libcode.org

Serj Kalichev c035ba0c79 xsd: PLUGIN declaration 9 hours ago
bin 6737fe1ea0 scheme: Use faux_error_sprintf() for error reporting 9 hours ago
docs d25a2514f2 lib: Add KTP dir 2 months ago
klish 6737fe1ea0 scheme: Use faux_error_sprintf() for error reporting 9 hours ago
libc 1a733d2882 Add internal getopt implamentation. BSD version 7 years ago
m4 cb8ca83a07 Fix ax_lua.m4 so that it skips the header version checks and assumes they're ok when cross-compiling. Use ax_lua.m4's facilities to locate Lua libs and headers 8 years ago
tinyrl d78768b041 build: Fix warning about --version-info 4 months ago
.clang-format a22ee5775c Formatting fixes 10 months ago
.gitignore 0637d7205e Add easy 'make deb' target. Thanks to Konstantin Kharlamov 2 months ago
CHANGES c8d65326ed fix 2 links, typos, describes args* attributes 2 years ago
ChangeLog edce0a7c8e Adding Debian package required files 8 years ago
Doxyfile ebf0742663 Update faux/ctype files 11 months ago
ISSUES c8d65326ed fix 2 links, typos, describes args* attributes 2 years ago
LICENCE b81ff592c3 From: Emmanuel Deloget <logout@free.fr> 8 years ago
Makefile.am e630f2918a scheme: Unfinished work on kview 1 week ago
README 5d137b4b45 Update README file 2 months ago
autogen.sh 8cdf6d307a Create m4 dir within autogen.sh script 8 years ago
configure.ac d78768b041 build: Fix warning about --version-info 4 months ago
indent.sh 9d6b47ec4d Wrapper for indent utility 1 year ago
klish.xsd c035ba0c79 xsd: PLUGIN declaration 9 hours ago

README

# Klish Project

The klish is a framework for implementing a CISCO-like CLI on a UNIX systems.

NOTE: It's a development branch for fully rewritten klish version 3.
It's not functional for now.
For stable klish version 2 see the "2.2" branch.


## Homepage

http://klish.libcode.org.


## Documentation

See the homepage and sourcecode tree "doc/" dir for documenation.


## Repository

https://src.libcode.org/pkun/klish

NOTE:
You need branch "master" for development non-stable version.
You need branch "2.2" for stable version.


## Contributing

Use klish mailing list http://groups.google.com/group/klish-dev to send patches.
The best practice is to use "git format-patch" to format patch and "git send-email" to send it.
It's great when the patch (or email) contain description for patch.


## Build

The development master branch needs libfaux (http://faux.libcode.org) to be built.
The stable branch 2.2 doesn't need libfaux library.