rules 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. #export DH_VERBOSE=1
  4. SRCTOP = `pwd`
  5. DESTDIR = $(SRCTOP)/debian/tmp
  6. INST_OWN = -o root -g root
  7. MAKE_DIR = install -p -d $(INST_OWN) -m 755
  8. INST_FILE = install -c $(INST_OWN) -m 644
  9. INST_PROG = install -c $(INST_OWN) -m 755 -s
  10. INST_SCRIPT = install -c $(INST_OWN) -m 755
  11. build: build-arch build-indep
  12. build-arch: build-stamp
  13. build-indep: build-stamp
  14. build-stamp:
  15. dh_testdir
  16. ./configure --prefix=/usr
  17. touch build-stamp
  18. clean:
  19. dh_testdir
  20. dh_testroot
  21. [ ! -f Makefile ] || $(MAKE) distclean
  22. rm -f build-stamp
  23. dh_clean
  24. install: build
  25. dh_testdir
  26. dh_testroot
  27. dh_prep
  28. dh_installdirs
  29. $(MAKE) install DESTDIR=$(DESTDIR) LIBTOOL=libtool
  30. dh_install
  31. # Build architecture-independent files here.
  32. binary-indep: build install
  33. dh_testdir
  34. dh_testroot
  35. dh_installchangelogs ChangeLog
  36. dh_installdocs
  37. dh_installexamples
  38. dh_installdebconf
  39. dh_installman
  40. dh_link
  41. dh_compress
  42. dh_fixperms
  43. dh_strip
  44. dh_installdeb
  45. dh_shlibdeps
  46. dh_gencontrol
  47. dh_md5sums
  48. dh_builddeb
  49. # Build architecture-dependent files here.
  50. binary-arch:
  51. binary: binary-indep binary-arch
  52. .PHONY: build clean binary-indep binary-arch binary install