rules 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. #!/usr/bin/make -f
  2. # Uncomment this to turn on verbose mode.
  3. #export DH_VERBOSE=1
  4. SRCTOP = `pwd`
  5. DESTDIR = $(SRCTOP)/debian/tmp
  6. INST_OWN = -o root -g root
  7. MAKE_DIR = install -p -d $(INST_OWN) -m 755
  8. INST_FILE = install -c $(INST_OWN) -m 644
  9. INST_PROG = install -c $(INST_OWN) -m 755 -s
  10. INST_SCRIPT = install -c $(INST_OWN) -m 755
  11. build: build-stamp
  12. build-stamp:
  13. dh_testdir
  14. ./configure --prefix=/usr
  15. touch build-stamp
  16. clean:
  17. dh_testdir
  18. dh_testroot
  19. -$(MAKE) distclean
  20. rm -f build-stamp
  21. dh_clean
  22. install: build
  23. dh_testdir
  24. dh_testroot
  25. dh_prep
  26. dh_installdirs
  27. $(MAKE) install DESTDIR=$(DESTDIR) LIBTOOL=libtool
  28. rm -rf $(DESTDIR)/usr/include
  29. install -m 755 $(SRCTOP)/contrib/konfd.init.debian $(DESTDIR)/etc/init.d/konfd
  30. cp $(SRCTOP)/contrib/clish/* $(DESTDIR)/etc/clish/
  31. dh_install
  32. # Build architecture-independent files here.
  33. binary-indep: build install
  34. dh_testdir
  35. dh_testroot
  36. dh_installchangelogs ChangeLog
  37. dh_installdocs
  38. dh_installexamples
  39. dh_installdebconf
  40. dh_installman
  41. dh_link
  42. dh_compress
  43. dh_fixperms
  44. dh_installdeb
  45. dh_shlibdeps
  46. dh_gencontrol
  47. dh_md5sums
  48. dh_builddeb
  49. # Build architecture-dependent files here.
  50. binary-arch:
  51. binary: binary-indep binary-arch
  52. .PHONY: build clean binary-indep binary-arch binary install